Please note: This project is no longer active. The website is kept online for historic purposes only.
If you´re looking for a Linux driver for your Atheros WLAN device, you should continue here .

Ticket #1473 (closed defect: fixed)

Opened 12 years ago

Last modified 11 years ago

Patched into kernel - compile error in ath_hal/ah_os.c:560

Reported by: anonymous Assigned to:
Priority: major Milestone: version 0.9.5
Component: madwifi: HAL Version: trunk
Keywords: Cc:
Patch is attached: 0 Pending:

Description

I'm trying to compile madwifi r2625 as part of the kernel 2.6.20 on a x86 Debian Etch system. After patching and configuring the kernel, while running make-kpkg it stops with

$ sudo make-kpkg --revision=mad2625 kernel_image
  ...
  CC [M]  drivers/net/wireless/madwifi/ath/if_ath_pci.o
  LD [M]  drivers/net/wireless/madwifi/ath/ath_pci.o
  CC [M]  drivers/net/wireless/madwifi/ath_hal/ah_os.o
drivers/net/wireless/madwifi/ath_hal/ah_os.c:560: error: expected ',' or ';' before 'TARGET'
make[6]: *** [drivers/net/wireless/madwifi/ath_hal/ah_os.o] Error 1

Change History

07/30/07 14:49:54 changed by mentor

I would recommend building madwifi as an out-of-tree module. I don't think it makes sense to patch madwifi into the kernel at the current time.

07/30/07 16:32:52 changed by mentor

  • summary changed from compile error in ah_os.c line 560 to Patched into kernel - compile error in ath_hal/ah_os.c:560.

07/30/07 20:41:00 changed by anonymous

If I replace ah_os.c with its pre-r2512 version it compiles without errors. The madwifi-kernel seems to work fine, I haven't seen any issues so far.

07/31/07 01:03:33 changed by mentor

  • status changed from new to closed.
  • resolution set to fixed.

r2626

(patching into the kernel may work, but that doesn't make it a good idea...)

07/31/07 01:03:54 changed by mentor

  • milestone set to version 0.9.4.

02/11/08 06:21:39 changed by mrenzmann

  • milestone changed from version 0.9.4 to version 0.9.5.