Please note: This project is no longer active. The website is kept online for historic purposes only.
If you´re looking for a Linux driver for your Atheros WLAN device, you should continue here .

Ticket #1470 (closed defect: fixed)

Opened 12 years ago

Last modified 10 years ago

compilation error when AHB chosen as BUS instead of PCI

Reported by: mkaraca5@mynet.com Assigned to:
Priority: minor Milestone: version 0.9.5
Component: madwifi: driver Version: v0.9.3.1
Keywords: BUS AHB Cc:
Patch is attached: 0 Pending: 0

Description

when i tried to compile for AHB bus i got the following errors:
# make BUS=AHB
.
.
.
if_ath_ahb.c: In function `init_ahb':
if_ath_ahb.c:434: error: `wlanNum' undeclared (first use in this function)
if_ath_ahb.c:434: error: (Each undeclared identifier is reported only once
if_ath_ahb.c:434: error: for each function it appears in.)


i simply changed the line 434 from:

config.unit = wlanNum;

to:

config.unit = 0;


it did compiled but i don't know what will happen when i use it. what should i do?

Change History

07/28/07 19:02:34 changed by mentor

  • status changed from new to closed.
  • resolution set to fixed.
  • milestone set to version 0.9.4.

I believe r2625 fixes this problem.

02/11/08 06:21:36 changed by mrenzmann

  • milestone changed from version 0.9.4 to version 0.9.5.

08/13/09 18:53:10 changed by proski

  • pending changed.

r2625 was bogus. The is no reason to set unit to 0. It can be 1. The code prior to r2130 was doing it correctly in init_ath_wmac(). The bogus code was removed from the trunk when the support for AHB on older kernels was removed. As for the 0.9.4 branch, the problem is fixed by r4085.