Please note: This project is no longer active. The website is kept online for historic purposes only.
If you´re looking for a Linux driver for your Atheros WLAN device, you should continue here .

Ticket #1464 (new defect)

Opened 14 years ago

Last modified 14 years ago

system hang w/ wpa_supplicant on beacon miss

Reported by: slawrence@pingtel.com Assigned to:
Priority: major Milestone:
Component: madwifi: driver Version: v0.9.3
Keywords: wpa_supplicant Cc:
Patch is attached: 0 Pending:

Description (Last modified by mentor)

I am getting frequent system hangs (everything frozen - have to power cycle) when using madwifi on linux (fc6) under the control of NetworkManager with wpa_supplicant.

The problem appears to happen when there is a beacon miss; I find many many repetitions of:

Jul 25 09:21:34 localhost NetworkManager: <information> wpa_supplicant(3275): CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys
Jul 25 09:21:34 localhost NetworkManager: <information> wpa_supplicant(3275): Associated with 00:19:a9:41:35:30
Jul 25 09:21:34 localhost NetworkManager: <information> wpa_supplicant(3275): CTRL-EVENT-CONNECTED - Connection to 00:19:a9:41:35:30 completed
 (reauth)

in /var/log/messages (after I've rebooted).

This problem is easily reproducible (that is, depending on where I am it takes from a few minutes to an hour for it to happen).

System info:

ThinkPad T43
> lspci | grep Atheros
0b:02.0 Ethernet controller: Atheros Communications, Inc. AR5212 802.11abg NIC (rev 01)

>  uname -r -v
2.6.20-1.2948.fc6 #1 SMP Fri Apr 27 19:48:40 EDT 2007

> rpm -qa | grep madwifi
kmod-madwifi-0.9.3-1.2.6.20_1.2925.fc6
madwifi-0.9.3-1.lvn6
madwifi-hal-kmdl-2.6.20-1.2948.fc6-0.9.3-35.fc6
madwifi-kmdl-2.6.20-1.2948.fc6-0.9.3-35.fc6

Change History

07/26/07 01:35:00 changed by mentor

  • priority changed from critical to major.
  • description changed.

07/26/07 06:12:02 changed by mrenzmann

Please check out the current release candidate of v0.9.3.2, it contains an enhancement that should prevent beacon misses as good as possible. You can grab it with svn co http://svn.madwifi.org/releases/0.9.3 madwifi-0.9.3.2-rc.

(follow-up: ↓ 4 ) 07/26/07 16:41:38 changed by slawrence@pingtel.com

Build and installed ok.... I'm running it now, and the netowrk I'm on has triggered the problem pretty frequently, so if I get through the day I'll call it fixed

(in reply to: ↑ 3 ) 07/27/07 06:52:32 changed by mrenzmann

Replying to slawrence@pingtel.com:

so if I get through the day I'll call it fixed

I'm crossing fingers...

07/27/07 16:29:59 changed by slawrence@pingtel.com

An update...

The new build is certainly better. I had a couple of occasions yesterday in which the wireless disconnected and then NetworkManager triggered a successful reconnect. Looking at /var/log/messages, I saw the same pattern of messages I'd seen before, but it did not lock up the system.

However, I did also have one time when I did get the lockup, with the same sequence in the log.

I'll be off this particular net in a couple of hours, but I've seen this elsewhere and will be more than happy to contine testing. If there is anything I can do to collect more data, please let me know.