Please note: This project is no longer active. The website is kept online for historic purposes only.
If you´re looking for a Linux driver for your Atheros WLAN device, you should continue here .

Ticket #1399 (closed defect: fixed)

Opened 12 years ago

Last modified 11 years ago

Complete system freeze with AR5212 on X86-64

Reported by: perchrh-madwifi@pvv.org Assigned to:
Priority: critical Milestone: version 0.9.5
Component: madwifi: other Version: trunk
Keywords: system freeze x86-64 smp Cc:
Patch is attached: 0 Pending:

Description (Last modified by dyqith)

With heavy network traffic my computer completely freezes. 
To reproduce, I visit a big website or download a big file from a quick site, e.g. a kernel from ftp.kernel.org

The problem occurs on 2.6.20-ubuntu-latest, stock 2.6.21.3 and 2.6.22-rc5 (no difference seen) 
using madwifi/trunk w/default options on an SMCWPCI-G EU on x86-64 smp (intel core 2 duo).
I've attached my .config for 2.6.22-rc5. Alt-sysrq doesn't work after the crash, and I get no messages from ath_pci in the kernel logs, even though I set 'sysctl -w dev.ath.debug=0xFFF'

This is what happened right before the crash (from /var/log/kernel.log):

Jun 19 23:15:03 helten NetworkManager: <information>^Iwpa_supplicant(5362): WPA: RX EAPOL-Key - hexdump(len=139): 01 03 00 87 fe 03 a2 00 2
0 00 00 00 00 00 00 00 07 08 b9 61 09 42 49 ee f9 5d 0e c2 ed 2d 2c 95 af d6 6c f4 60 5b 0b 52 eb a7 41 da 0e 73 c8 9c 16 42 97 78 8d b0 34
 eb a1 58 17 bb 60 f0 dd d9 4b 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 b3 7b 63 ed 12 67 2b 60 57 29 96 c4 a2 2b 34 1c 00 28 41 3a
48 43 8e 92 92 9e 17 6e 28 c4 b9 c2 a9 f7 c8 cb 9f c7 18 4a 0c 81 96 f0 3b 0f a2 fc db 1e 8d 6e 16 f7 69 7c dd 1d
Jun 19 23:15:03 helten NetworkManager: <information>^Iwpa_supplicant(5362): WPA: RX message 1 of Group Key or STAKey Handshake from 00:17:9
a:b0:9b:79 (ver=2)
Jun 19 23:15:03 helten NetworkManager: <information>^Iwpa_supplicant(5362): State: COMPLETED -> GROUP_HANDSHAKE
Jun 19 23:15:03 helten NetworkManager: <information>^Iwpa_supplicant(5362): WPA: Group Key - hexdump(len=32): [REMOVED]
Jun 19 23:15:03 helten NetworkManager: <information>^Iwpa_supplicant(5362): WPA: Installing GTK to the driver (keyidx=2 tx=0).
Jun 19 23:15:03 helten NetworkManager: <information>^Iwpa_supplicant(5362): WPA: RSC - hexdump(len=6): 00 00 00 00 00 00
Jun 19 23:15:03 helten NetworkManager: <information>^Iwpa_supplicant(5362): wpa_driver_madwifi_set_key: alg=TKIP key_idx=2 set_tx=0 seq_len
=6 key_len=32
Jun 19 23:15:03 helten NetworkManager: <information>^Iwpa_supplicant(5362): WPA: Sending EAPOL-Key 2/2

Attachments

config-perchrh (34.3 kB) - added by perchrh-madwifi@pvv.org on 06/19/07 23:49:17.
config for linux-2.6.22-rc5
syslog-henper (11.8 kB) - added by perchrh-madwifi@pvv.org on 06/20/07 00:05:50.
More complete and not mangled by bad formatted

Change History

06/19/07 23:49:17 changed by perchrh-madwifi@pvv.org

  • attachment config-perchrh added.

config for linux-2.6.22-rc5

06/20/07 00:05:50 changed by perchrh-madwifi@pvv.org

  • attachment syslog-henper added.

More complete and not mangled by bad formatted

06/20/07 00:31:49 changed by dyqith

  • description changed.

06/20/07 00:33:10 changed by dyqith

Can you also state the revision of svn trunk ?

06/20/07 08:18:55 changed by strasak@bubakov.net

you have restarted the box by hand? If yes, please turn on NMI watchdog and let it be frozen for some time, it should restart the box and throw oops message on you, which would be very helpful. I think this could be related to ticket #1325, behavior is the same - freeze,sysrq not working, only nmi watchdog catch it, it is on i386 but could be related anyway. Also, try to go back to 0.9.3.1, it is rock solid for me on that smp machine where trunk hangs, as described in above mentioned ticket. Maybe i will assemble some test machine for X86-64 soon too and try to reproduce it.
BTW, have you tried trunk version after dyqith fix of double-locking ? It is fixed in trunk in changeset 2486, commited yesterday

06/20/07 09:01:50 changed by anonymous

Revision: I can reproduce with revision 2485 and a number of prior revisions (all the ones I tried). I will try enabling NMI wathcdog to get the oops. And r2486. Thanks. Also should maybe mention that memtest86+ passes.

06/20/07 22:18:11 changed by perchrh-madwifi@pvv.org

I tried r2492 w/the irq locking fix and my problems went away! I'm so happy :) Thanks guys, especially dyqith for fixing the bug!

06/20/07 23:06:55 changed by dyqith

  • status changed from new to closed.
  • resolution set to fixed.

No thanks needed, I'm required to fix bugs. ;) I slacked off the last 12 months and haven't put much effort into madwifi.... so I'm catching up now.

06/27/07 11:59:00 changed by mrenzmann

  • milestone set to version 0.9.4.

02/11/08 06:20:23 changed by mrenzmann

  • milestone changed from version 0.9.4 to version 0.9.5.