Please note: This project is no longer active. The website is kept online for historic purposes only.
If you´re looking for a Linux driver for your Atheros WLAN device, you should continue here .

Ticket #1369 (closed defect: fixed)

Opened 12 years ago

Last modified 11 years ago

unstable behavior of trunk on mipsel platform - RB532 and similar

Reported by: strasak@bubakov.net Assigned to:
Priority: minor Milestone: version 0.9.5
Component: madwifi: driver Version: trunk
Keywords: unstable, lock, routherboard Cc:
Patch is attached: 0 Pending:

Description

During testing of madwifi stability and throughtput - and also searching for more informations related to #1272 - on above mentioned mipsel platform - RB532 and RB532A nd another variants - i have found, that latest trunk behaves bad on this platform. As first shoot - being busy and primarily want to test NAPI patch and other stuff related to above mentioned ticket - i have checked trunk revision 2380, before massive locking changes. This one works perfectly stable - not mentioning #1272 but that doesn't matter here. Today i will try revisions around 2414, where known problems introduced in 2381 has been fixed, but i think it will behave the same as 2433 which i'have tested.

The problem is:

i have tested RB532 + RB502 - capable of 4 minipci cards - if i enable one atheros device - ifconfig up - it starts to scan and box becomes unresponsible for few seconds. After it associates, all works, but there are random glitches - periods of unresponsibility, throught wireless or wired conection and even over serial line. When i enable second device, box become extremely unresposible, and after some time it just hangs. No reaction over serial line, no crash or oops in syslog, so i guess hardware lockup come into place... . What is important, it doesn't happen - nor the initial period of unresposivnes during initial scan/association, nor the later random periods of it, nor then total hangup after enabling second card - on 0.9.3.1, it doesn't happen on all older revisions of trunk before 2381. If anyone will be so kind and test current trunk on similar device, it would be nice. I will dig into this more and report all news as usual.

Change History

07/01/07 10:40:48 changed by strasak@bubakov.net

After some days of testing i can say that most likely this problem is solved by locking changes + fixes of double locking - stuff fixed in #1368 has been primary source of this i guess. So, i think it could be closed.

07/01/07 13:26:37 changed by mentor

  • status changed from new to closed.
  • resolution set to fixed.
  • milestone set to version 0.9.4.

Thanks

02/11/08 06:19:48 changed by mrenzmann

  • milestone changed from version 0.9.4 to version 0.9.5.