Please note: This project is no longer active. The website is kept online for historic purposes only.
If you´re looking for a Linux driver for your Atheros WLAN device, you should continue here .

Ticket #1332 (closed defect: fixed)

Opened 12 years ago

Last modified 12 years ago

adhoc mode freeze under linux

Reported by: dasnake@gmail.com Assigned to:
Priority: major Milestone: version 0.9.5
Component: madwifi: other Version: trunk
Keywords: Cc:
Patch is attached: 0 Pending:

Description

The problem is: if I create an adhoc interface:

# wlanconfig ath0 destroy
# wlanconfig ath0 create wlandev wifi0 wlanmode adhoc

and then setup:

# iwconfig ath0 essid "someessid"
# iwconfig ath0 channel 3

and then bring the interface up:

# ifconfig ath0 up

The system suddendly hang up. I've tried enabling debug (80211ieee +debug) bug it hangs before any message. There's no Kernel oops too. It just stops, with caps lock blinking.

The problem is present only if radio is on, and if I turn up the interface with radio off nothing happens until I switch radio on, then hangs.

My hardware is an Acer laptop, TravelMate? 371 TCi.

I've this problem with both trunk (r2359) and 0.9.3 version, with both kernels 2.6.20.6 and 2.6.21.1.

If there is some more information I can provide, please ask.

Change History

05/21/07 20:55:34 changed by mentor

  • priority changed from critical to major.

05/23/07 16:18:16 changed by dasnake

Upgrading to r2366 solved the issue. I guess is the new HAL that fixed the problem

05/24/07 09:27:54 changed by mrenzmann

  • status changed from new to closed.
  • resolution set to fixed.
  • milestone set to version 0.9.4.

Thanks for the feedback, I close this ticket as fixed.

02/11/08 06:18:28 changed by mrenzmann

  • milestone changed from version 0.9.4 to version 0.9.5.