Please note: This project is no longer active. The website is kept online for historic purposes only.
If you´re looking for a Linux driver for your Atheros WLAN device, you should continue here .

Ticket #1223 (new defect)

Opened 15 years ago

Last modified 15 years ago

Softled kills RF transmit power

Reported by: nils@kernelconcepts.de Assigned to:
Priority: minor Milestone:
Component: madwifi: driver Version: trunk
Keywords: softled rfkill Cc:
Patch is attached: 0 Pending:

Description

Hi!

I have a "normal" non-IBM AR5212 based miniPCI card installed in an IBM X31 notebook. The card works fine by default but the X31 built-in wifi LED does not work by default.

If I set dev.wifi0.softled=1 then the LED starts to blink as expected but sending of data does not seem to work anymore! Using iwlist I still see all stations with the correct reception levels (also changing levels) but I cannot associate with any access point.

I also tried with "ath_pci rfkill=1" but with quite exactly same effect.

Since I like the LED quite a lot I would love to see this working ;) Any hints welcome, I would also be willing to test patches or other tricks, send mail to nils@kernelconcepts.de

Thanks!

Change History

03/27/07 06:49:25 changed by mrenzmann

  • reporter changed from anonymous to nils@kernelconcepts.de.

Do you have any chance to get a second WLAN client in place that could run in monitor mode to see whether the card really stops sending packets?

04/03/07 01:03:44 changed by nils@kernelconcepts.de

Well, though I am pretty sure about my observation I will try proof my theory by the test you propose ;) Thanks!