Please note: This project is no longer active. The website is kept online for historic purposes only.
If you´re looking for a Linux driver for your Atheros WLAN device, you should continue here .

Ticket #120 (closed defect: worksforme)

Opened 14 years ago

Last modified 11 years ago

countrycode problem since new HAL (0.9.16.3)

Reported by: Stijn Tintel <stijn@linux-ipv6.be> Assigned to:
Priority: major Milestone: version 1.0.0 - first stable release
Component: madwifi: HAL Version: trunk
Keywords: Cc:
Patch is attached: 0 Pending:

Description

Since the introduction of the new HAL (0.9.16.3) in r1260, I cannot specify countrycode=56 anymore. If I do, the wifiX device doesn't appear. This is the error I'm getting in dmesg:

ath_pci: 0.9.4.5 (Atheros/multi-bss)
PCI: Found IRQ 10 for device 0000:00:10.0
wifi%d: unable to collect channel list from hal; regdomain likely 48 country code 56

Change History

11/03/05 12:35:08 changed by Stijn Tintel <stijn@linux-ipv6.be>

I forgot to mention this, but I did not have this problem with revisions < r1260 when specifying countrycode=56.

11/03/05 12:35:44 changed by br1

please show sysctl -a|grep dev.ath

11/03/05 12:45:54 changed by Stijn Tintel <stijn@linux-ipv6.be>

Modprobed with countrycode=56, no wifiX device:

tweety:~/drivers/madwifi-ng# modprobe ath_pci countrycode=56
tweety:~/drivers/madwifi-ng# sysctl -a |grep "dev.ath"
dev.ath.calibrate = 1
dev.ath.xchanmode = 1
dev.ath.outdoor = 0
dev.ath.regdomain = 0
dev.ath.countrycode = 56
dev.ath.debug = 0
dev.ath.hal.swba_backoff = 0
dev.ath.hal.sw_beacon_response_time = 10
dev.ath.hal.dma_beacon_response_time = 2

Modprobed without parms, wifi0 exists:

tweety:~/drivers/madwifi-ng# modprobe ath_pci
tweety:~/drivers/madwifi-ng# sysctl -a |grep "dev.ath"
dev.ath.calibrate = 1
dev.ath.xchanmode = 1
dev.ath.outdoor = 0
dev.ath.regdomain = 0
dev.ath.countrycode = 0
dev.ath.debug = 0
dev.ath.hal.swba_backoff = 0
dev.ath.hal.sw_beacon_response_time = 10
dev.ath.hal.dma_beacon_response_time = 2

11/03/05 12:57:54 changed by br1

hmm, strange - works for me...

11/03/05 13:15:46 changed by br1

  • milestone set to version 1.0.0 - first stable release.

11/09/05 16:47:09 changed by davyd@madeley.id.au

I cannot specify countrycode 36 (Australia). It has not worked with any version of the driver so far (last tested with madwifi-ng on 2005-11-09).

This error is returned:

unable to collect channel list from hal; regdomain likely 100 country code 36

Have attempted to use xchanmode=1 and outdoor=1 along with countrycode in a variety of combinations to get the extra channels that are used in Australia. All with no success.

This Atheros is a mini-pci card on a Toshiba laptop purchased in Australia.

11/18/05 19:47:38 changed by milon@wq.cz

I see the same problem with card AG-621 (zcomax). But cards named CM9 (I don't know producer exactly (may be wistron neweb corp.)) are working. So it may be producer dependent. Unfortunately I have only one ag-621 card. I hope it helps.

12/14/05 08:42:44 changed by mrenzmann

The problem seems to be that the HAL doesn't allow the combination of the regdomain (from EEPROM) and the given countrycode (from module parameter countrycode). I've seen several reports like that during the last weeks. Forwarding to Atheros.

12/27/05 22:48:01 changed by Stijn Tintel <stijn@linux-ipv6.be>

I've tried using the new HAL version 0.9.16.13 (#258), but it has the same problem:

ath_hal: 0.9.16.13 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413, DFS)
wlan: 0.8.4.2 (Atheros/multi-bss)
ath_rate_sample: 1.2
ath_pci: 0.9.4.5 (Atheros/multi-bss)
PCI: Found IRQ 10 for device 0000:00:10.0
wifi%d: unable to collect channel list from hal; regdomain likely 48 country code 56

01/27/06 11:15:25 changed by mrenzmann

Sorry for the long delay, my queue was (and still is) congested. Forwarded this issue to Atheros today.

03/02/06 02:05:16 changed by Stijn Tintel <stijn@linux-ipv6.be>

  • patch_attached changed.

Today I received a Netgear WG511T, which was kindly sent to me by p0g0. After inserting it into my laptop's PCMCIA slot and compiling madwifi-ng, I tried loading ath_pci with countrycode=56, and with this card it seems to load without problems.

Output of sysctl -a|grep dev.ath with WG511T and countrycode=56:

dev.ath.calibrate = 30
dev.ath.xchanmode = 1
dev.ath.outdoor = 0
dev.ath.regdomain = 0
dev.ath.countrycode = 56
dev.ath.debug = 0
dev.ath.hal.swba_backoff = 0
dev.ath.hal.sw_beacon_response_time = 10
dev.ath.hal.dma_beacon_response_time = 2

The card I reported this problem for is a D-Link DWL-G520 (HW: A1, FW: 2.23, IIRC). The problem still exists with this card and HAL version 0.9.16.16. It seems indeed that this is card and/or vendor specific. However, specifying countrycode=56 worked with this card and HAL version before 0.9.16.3, so it would be nice if this issue could be solved in a future HAL release.

Maybe this information is also useful?

DWL-G520:

wifi0: mac 5.6 phy 4.1 radio 1.7

WG511T:

wifi0: mac 5.9 phy 4.3 radio 4.6

03/23/06 04:52:24 changed by Stijn Tintel <stijn@linux-ipv6.be>

I've verified that countrycode=56 works fine with my DWL-G520 and HAL versions 0.9.15.1 (madwifi-ng) and 0.9.14.9 (madwifi-old).

Output of sysctl -a|grep dev.ath with HAL 0.9.15.1:

dev.ath.calibrate = 30
dev.ath.xchanmode = 1
dev.ath.outdoor = 0
dev.ath.regdomain = 0
dev.ath.countrycode = 56
dev.ath.debug = 0
dev.ath.hal.swba_backoff = 0
dev.ath.hal.sw_beacon_response_time = 10
dev.ath.hal.dma_beacon_response_time = 2

Output of sysctl -a|grep dev.ath with HAL 0.9.14.9:

dev.ath.calibrate = 30
dev.ath.dwelltime = 200
dev.ath.xchanmode = 1
dev.ath.outdoor = 1
dev.ath.regdomain = 0
dev.ath.countrycode = 56
dev.ath.debug = 0
dev.ath.hal.swba_backoff = 0
dev.ath.hal.sw_beacon_response_time = 10
dev.ath.hal.dma_beacon_response_time = 2

05/16/06 08:56:15 changed by dyqith

So, these problems are based on the hardware ? Can someone put this stuff into the Compatibility page and once done close this ticket ?

05/16/06 09:50:19 changed by kelmo

Why close the ticket if it has not been satisfied yet? I think it should stay open until such a time that a new HAL actually fixes the problem (its a regression, not just a quirk).

05/16/06 17:00:51 changed by Stijn Tintel <stijn@linux-ipv6.be>

The problem seems to be hardware specific, but as I mentioned before, the same card worked nicely with countrycode=56 (for Belgium) with older HAL versions (tested 0.9.15.1 and 0.9.14.9).

I've also tried with HAL version 0.9.17.0 from http://people.freebsd.org/~sam/ath_hal-20060506.tgz, but that still doesn't fix this problem.

05/26/06 17:33:49 changed by mangia

I also have same problem. Tonze mPCI card and Slack 10.1 and Wifiware. No chance to change any countrycode. Module ath_pci doesn't recognise any countrycode. Also when I unload ath_pci ant try to get up ath0 interface it says that ath0 doesn't exist. I can get it up only if I load ath_pci without countrycode directive.

:(

06/28/06 09:42:32 changed by proski

Please don't be deceived by the value of dev.ath.regdomain. It's bogus and I've just removed it from the driver (r1659). The real regdomain should be in dev.wifi0.regdomain, and I guess it's 48.

08/01/06 16:08:38 changed by anonymous

dev.wifi0.regdomain is 48 for the d-link g520 rev a, however it is wrong as the card was purchased in the UK.

this appears to be a fault in the card which can be overcome in windows by using the wildpackets.com atheros driver as it allows any country to be set, yet with madwifi there is no such luck.

i find it hard to recommend this driver, thanks for the work anyway.

08/02/06 01:12:23 changed by anonymous

the above comment was in error, after much searching 48 would appear to be the correct id for the UK, however, it no longers appears to work.

using the tool here: sourceforge.net/mailarchive/message.php?msg_id=8966525

you can change the id from 48 to 55 which does allow the UK to be accepted, however, i have yet to see it allow anything > 39mw tx power, perhaps i am in error again, but it should go higher?

if this is resolved, more details will follow....

08/02/06 04:05:21 changed by proski

Let me sum up the problems reported here.

Stijn Tintel reports that a card with regdomain 48 (ETSI4_WORLD) is not compatible with countrycode 56 (Begium). I confirm this problem with HAL 0.9.17.2. According to the regdomain list, Belgium is in ETSI4_WORLD, so it should work, unless the rules have changed. It worked with older HAL.

davyd@madeley.id.au reports that regdomain 100 is not compatible with countycode 36 (Australia). Although regdomain of Australia is 33 (FCC2_WORLD), the card was bought in Australia and worked with older HAL.

Other reports are incomplete. We also don't know for sure that the regdomain in the cards wasn't reset by Windows drivers.

Regdomain list can be found at http://madwifi.org/attachment/wiki/Compatibility/RegDomain_CountryCode_Channel_list_802.11abg.rtf

07/17/07 15:14:07 changed by mtaylor

  • status changed from new to closed.
  • resolution set to worksforme.

This ticket has not been updated in over six months and is being marked as "works for me" automatically.

If the ticket is still applies to the head revision of trunk, please re-open the ticket and provide any additional details needed and progress on the problem to date. Thanks.

12/06/07 21:37:33 changed by Torsten Krah <tkrah@fachschaft.imn.htwk-leipzig.de>

I am using v 0.9.3.2 and HAL 0.9.18.0 - ubuntu 7.10 stuff. I should be able to use 100mW maximum power (like i can do in win32), but with madwifi i can only set this ones:

0 dBm (1 mW) 4 dBm (2 mW) 6 dBm (3 mW) 8 dBm (6 mW) 10 dBm (10 mW) 12 dBm (15 mW) 14 dBm (25 mW) 16 dBm (39 mW)

Changing the countrycode does still result in

unable to collect channel list from hal; regdomain likely ...

The card is a Allnet All0281A - sysctl:

dev.ath.hal.dma_beacon_response_time = 2 dev.ath.hal.sw_beacon_response_time = 10 dev.ath.hal.swba_backoff = 0 dev.ath.debug = 0 dev.ath.countrycode = 0 dev.ath.outdoor = 0 dev.ath.xchanmode = 1 dev.ath.calibrate = 30

Anything i can do?