Please note: This project is no longer active. The website is kept online for historic purposes only.
If you´re looking for a Linux driver for your Atheros WLAN device, you should continue here .

Ticket #1198 (closed defect: invalid)

Opened 12 years ago

Last modified 11 years ago

system freezes when loading the ath_pci module if I have my AR5212 connected. (ACPI issues??)

Reported by: cusco@tretas.eu Assigned to:
Priority: major Milestone:
Component: madwifi: other Version: trunk
Keywords: AR5212 freeze ath_pci etch Cc:
Patch is attached: 0 Pending:

Description

Hello! I'm using Debian testing (etch at the moment) and I tried the latest svn revision (2199) and the latest stable (0.9.2.1).

Problem is that when the ath_pci is loaded my system freezes, and when booting and it comes to load the ath_pci the last mensage I see is: ACPI: PCI Interrupt 0000:03:03.0[A] -> GSI 19 (level, low) -> IRQ 209
and I can't get past it. I will have to shutdown, take the card out and reboot. Note that the GSI and IRQ numbers change if I change the PCI slot where I plug my card, but the problem remains.

So I tried booting the kernel with the flag pci=noacpi.
Then my system got stuck but didn't display the IRQ PCI Interrupt line, only displayed the loading of the madwifi modules.

Then I tried to go on the bios to find any settings about irq's but the only I found was "is OS plug & play capalbe? YES or NO" and I changed it to NO. When booting then, I got one more line that I did't get before (and note that I'm still booting with the flag pci=noacpi). The line was: hda_codec: Unknown model for ALC882, trying auto-probe from BIOS... just after the madwifi modules being loaded. This mensage still comes if I have no card plugged in or no madwifi modules installed, and my system boots fine. hda??!? Im using sata drivers... wth?

I know this very same card worked on anoder machine also running debian testing with both madwifi-ng and madwifi old. Thanks very much for your atention.

Change History

03/19/07 14:37:59 changed by mrenzmann

  • priority changed from blocker to major.

What CPU architecture are you working with?

hda_codec: Unknown model for ALC882, trying auto-probe from BIOS...

This is a message from Alsa, where hda stands for "high definition audio".

Does your system work when you remove the WLAN card from your system? If so, try booting with your WLAN card inserted and the soundcard removed/disabled. Let us know of the results.

03/20/07 03:25:15 changed by cusco@tretas.eu

The architecture of my cpu seems to be a x86_64 (intel core 2) but Im running a x86 linux.

I don't get the line hda_codec after the ath_pci anymore in any way. Looks like the sound gets loaded at the same time but might vary from befor or after when udev is "getting populated"
After disabling the on-board sound on the bios settings, it kept the same.. freezed on the loading of ath_pci. Afterwards I turned on the sound, and the line input: PC Speaker as /class/input/input1 came in after the line that shows the laoding of wlan and before the ath_pci, thats why I say it just gets loaded about the same time, tho not being related....

03/22/07 23:22:45 changed by dv01dem@cs.umu.se

I have this problem as well. I have the same chip as you (AR5212) and a Core 2 Duo running gentoo x86_64. I have never been able to use the madwifi drivers and I've had this problem from january 2007 when I bought my computer. It doesn't matter whether I use v.0.9.2 or v.0.9.3.

Information of any progress regarding this would be much appreciated.

/ Daniel

03/23/07 23:06:35 changed by cusco

yea! I think its somehow down to the motherboard. as I said the same card worked well on another (and older) machine.
I bet that you, like me, have a HP Pavilion (mine beeing a m7000 series). :P

03/24/07 01:56:58 changed by dv01dem@cs.umu.se

My motherboard is a Gigabyte 965P-S3. My laptop is an HP Pavillion though (4075EA). It might be that there are some problems with the 965 chip, but I really don't know.

/ Daniel

03/24/07 20:19:44 changed by cusco

I think I'm giving up. My motherboard is a Asus P5BW-LA (looks like Asus makes this mobo custom for HP).
My bios is an Award (while asus's are AMI) and the latest I could find to flash was: hxxp://h10025.www1.hp.com/ewfrf/wc/genericSoftwareDownloadIndex?cc=au&dlc=en&lc=en&softwareitem=pv-45411-1&jumpid=reg_R1002_AUEN (note hxxp/http)
I have no options regarding the IRQ's besides disabling built-in audio, lan and some usb legacy...
I tried everything! last thing Im doing now, booting from the backtrack2 cd with no hard drives and the built in hardware disabled. If it doesn't work I'm giving up on this card with this motherboard

03/25/07 19:06:48 changed by cusco

OK I GAVE UP. [

[BR]] I discovered that Windows Vista also doesn't work. when installing the drivers it just got frozen, and after a reboot the device manager said the driver was installed with success but reported some error code 31.

I believe this is because of the same issue, and I believe it is down to the motherboard.
Good luck for you all.

03/25/07 20:51:41 changed by dv01dem@cs.umu.se

Damn it! Thanks for the information though.

/ Daniel

05/15/07 16:42:30 changed by GeorgeWingard

I tried loading Xp on to my Vista m7550n x2 5000+ No go!(have not tried sp2 Think I need to slipstream a cd cause this hardware is so new) Found Nvidia chipset drivers update on Nvidia website you might try this? Chipset seems flaky running vista with my 1000gb ethernet intel 1000pt card plugged into it(nightmare) I think we gotta wait for a bios revision as it looks as thou not much operating system was researched for this ASUSTEK board except vista(cant even find a bios update on asus site or recognition of the produced product)...It is really tough deciding wheather to hold on to this gem as all the components and specs seem so jaw droppingly awsome, HD audio one of them :)...

(follow-up: ↓ 11 ) 06/01/07 21:10:29 changed by mentor

  • status changed from new to closed.
  • resolution set to invalid.

Marking closed as invalid because this seems to be a motherboard/chipset/BIOS problem.

(in reply to: ↑ 10 ) 09/12/08 07:23:15 changed by andre.macassi@gmail.com

I found that I had a similar error spit out and kernel segmentation fault and crash of system with w311t when I tried to run the kernel without having multiple hardware tx queues option selected in the kernel. I have my card recognized and can scan for networks but cannot connect with or without encryption..