Please note: This project is no longer active. The website is kept online for historic purposes only.
If you´re looking for a Linux driver for your Atheros WLAN device, you should continue here .

Ticket #1191 (closed defect: duplicate)

Opened 15 years ago

Last modified 15 years ago

madwifi doesn't work on AR5005G?

Reported by: liu.xp1206@msa.hinet.net Assigned to:
Priority: major Milestone:
Component: madwifi: driver Version: trunk
Keywords: Cc:
Patch is attached: 0 Pending:

Description (Last modified by mrenzmann)

i use toshiba L30,and OS is fedora core6

i follow the UserDocs/FirstTimeHowTo step by setp

but my madwifi did not use the rpm(the step of UserDocs/Distro/RedHat),i downloaded madwifi-0.9.2.1.tar.gz and madwifi-ng-r2182-20070308.tar.gz

my install step is:

  1. make
  2. make install
  3. modprobe ath_pci

when i type iwconfig

eth0      no wireless extensions.

lo        no wireless extensions.

wifi0     no wireless extensions.

ath0      IEEE 802.11g  ESSID:""
          Mode:Managed  Frequency:2.457 GHz  Access Point: 00:00:00:00:00:00
          Bit Rate:0 kb/s   Tx-Power:20 dBm   Sensitivity=0/3
          Retry:off   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=0/94  Signal level=-95 dBm  Noise level=-95 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

but i wanted to scan AP,it can't find the AP

does it not work on my computer??? or i should install with theos rpms??

Change History

(follow-up: ↓ 6 ) 03/12/07 10:14:28 changed by mrenzmann

  • version set to trunk.
  • description changed.

We recently had several reports indicating that AR5005G support could be buggy. I have a card with AR5005G in my new notebook, and as soon as I find the time I will investigate that further.

03/12/07 11:41:31 changed by liu.xp1206@msa.hinet.net

thank for your reply,maybe i should buy a new pcmci card

and wait for your investigation,thanks

03/12/07 11:47:22 changed by mrenzmann

Looking at your description again, I miss the "ifconfig ath0 up". Unless the interface is set to UP, scanning won't work.

03/12/07 17:32:07 changed by anonymous

I was sure i set it,I try "ifconfig ath0 up" and "ifup ath0"

but it still scanned anything!!

03/26/07 05:18:56 changed by anonymous

I'm expierencing the same issue now after a new Ubuntu Feisty Fawn beta Release. (Yes, It is BETA, but hope you can work with Launchpad Motu on this issue

(in reply to: ↑ 1 ; follow-up: ↓ 7 ) 04/08/07 14:37:52 changed by idriss82@yahoo.fr

Replying to mrenzmann:

We recently had several reports indicating that AR5005G support could be buggy. I have a card with AR5005G in my new notebook, and as soon as I find the time I will investigate that further.

(in reply to: ↑ 6 ) 04/10/07 11:11:55 changed by mrenzmann

Replying to idriss82@yahoo.fr:

If the purpose of your comment was to ask whether I found the time to look at it: not yet, sorry. But it's still high up on my to-do list.

04/24/07 09:31:16 changed by mrenzmann

  • status changed from new to closed.
  • resolution set to duplicate.

Closing this as duplicate of #1206, which seems to have more useful information about this issue. Will provide a report of my Feisty tests there, too.