Please note: This project is no longer active. The website is kept online for historic purposes only.
If you´re looking for a Linux driver for your Atheros WLAN device, you should continue here .

Ticket #1186 (new defect)

Opened 15 years ago

Last modified 14 years ago

Ad-hoc is not working in 802.11a mode

Reported by: bartek@go3.pl Assigned to:
Priority: major Milestone:
Component: madwifi: other Version:
Keywords: Cc:
Patch is attached: 0 Pending:

Description

A have ad-hoc link betwean to hosts. Recently I tryed to change this link from 802.11g to 802.11a ( I changed antennas to 5GHz). iwconfig shows that card is working in ad-hoc but I can't ping other side. When I tryed to make link sta->ap in 802.11a it works fine. I'm useing madwifi version madwifi-ng-0.9.2.1

Change History

11/02/07 16:06:47 changed by Mathias Bavay

I confirm: I've been trying to use a CM9 (mini-pci) card that has an Atheros AR5213A chipset with madwifi in 802.11a in ad-hoc mode, it does not work at all. Scanning (with iwlist ath0 scan) worked only a handful of times and failed most of the time (saying that no scan was available). When I moved to master/managed mode, it simply worked (on the same channel).

I am using an Alix board and a Wrap board, both with a CM9 card. They both run Voyage Linux 0.4 (kernel 2.6.20) with wireless tools version 29 and wireless extension version 21. I establish the communication between the two boards (currently sitting 1 inch from each other, so the distance is not the reason!)