Please note: This project is no longer active. The website is kept online for historic purposes only.
If you´re looking for a Linux driver for your Atheros WLAN device, you should continue here .

Ticket #1110 (new defect)

Opened 15 years ago

Last modified 14 years ago

modprobe ath_pci hard freeze kernel. Proxim 8482-WD PCI card.

Reported by: leonard.khoo@gmail.com Assigned to:
Priority: major Milestone:
Component: madwifi: driver Version: v0.9.2.1
Keywords: Cc:
Patch is attached: 0 Pending:

Description (Last modified by mrenzmann)

modprobe ath_pci hard freezes the kernel. This is not hardware issue. Tried with 2 identical cards. I am not sure how to debug since it hard freezes and there is no information in /var/log/messages.

kernel: 2.6.19.2/ gentoo-sources-2.6.19-r4
System: Gentoo x86 (32bit)
drivers: madwifi-ng-0.9.2.1 and madwifi-ng-r1995-20070124

Proxim 8482-WD PCI card.(atheros 5001x+)
05:00.0 Ethernet controller: Atheros Communications, Inc. AR5212 802.11abg NIC (rev 01)
Subsystem: PROXIM Inc 8482-WD ORiNOCO 11a/b/g Wireless PCI Adapter
Flags: bus master, medium devsel, latency 64, IRQ 3
Memory at fa000000 (32-bit, non-prefetchable) [size=64K]
Capabilities: [44] Power Management version 2

Portage 2.1.2-r3 (default-linux/x86/2006.1, gcc-4.1.1, glibc-2.5-r0, 2.6.19-beyond3 i686)
System uname: 2.6.19-beyond3 i686 Intel(R) Core(TM)2 CPU          6300  @ 1.86GHz
Gentoo Base System version 1.12.9
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17
sys-devel/gcc-config: 1.3.14
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.19.2-r1

Change History

01/25/07 12:52:37 changed by mrenzmann

  • description changed.

Is the issue reproducable? If so, what steps are required for that?

01/25/07 13:26:18 changed by anonymous

I just tried madwifi-old-r1417-20060128, it hard freezes kernel as well.

Yes, its reproducable. Download driver, make && make install. Then "modprobe ath_pci" will hang the kernel. Various kernel options are all compiled in such as wireless extension and various encryption algorithm.

Let me know if you need more info. Thanks

01/26/07 06:08:20 changed by mrenzmann

Just to be sure: it freezes immediately when you modprobe ath_pci?

Do you have a serial port and a second box available? If so, you could see if the tips from DevDocs/KernelOops about setting up a serial console help. There are kernel options that help to investigate such issues, too.

You have a Core2 CPU, so how is the kernel compiled, with or without SMP support?

01/26/07 23:32:35 changed by anonymous

I'll try test it out on another box and use the KernelOops? tips. The kernel has SMP enabled.

01/27/07 06:35:56 changed by leonard.khoo@gmail.com

Yes, it does freezes immediately after modprobe. I've just tried a kernel without SMP and its still the same problem.

02/01/07 18:07:16 changed by leonard.khoo@gmail.com

The 8482-WD PCI card is actually a mini pci in a PCI holder. I've got two of these cards, so I removed one of the mini pci card from the holder and put it into my laptop. It works flawlessly. The PCI still hangs with the latest build.

05/31/07 04:05:14 changed by anonymous

Same issue with ubuntu feisty on a Macbook C2D ...

06/05/07 23:05:08 changed by anonymous

same on Debian unstable. But freezed at random time. Sometimes the system recover, but no error in logs.

06/05/07 23:07:53 changed by anonymous

sorry, here some more infos (Debian unstable): system is an ibm thinkpad t30 with a Atheros (AR5212) mini-pci-card

06/21/07 22:33:55 changed by mtaylor

This is an ambiguous request. 1) Can we find something more concrete in the logs? 2) Can anyone reproduce it with the latest trunk? 3) If not, how do we know all these 'crash on modprobe' errors are related?

08/16/07 04:52:29 changed by Daguerre

Hate to add more ambiguous data, but I too have intermittent hard freezes when using a known-good Netgear WG311T PCI card, but I think only when VMware Workstation has bridged a virtual interface over the wlan. VMware isn't supposed to be able to bridge a wireless NIC at all, but there's a "fix" I found here[ht tp://ubuntuforums.org/showthread.php?t=285846] that had me comment out these lines from if_ath.c: #ifdef USE_HEADERLEN_RESV dev->hard_header_len += sizeof(struct ieee80211_qosframe) + sizeof(struct llc) + IEEE80211_ADDR_LEN + IEEE80211_WEP_IVLEN + IEEE80211_WEP_KIDLEN; #ifdef ATH_SUPERG_FF dev->hard_header_len += ATH_FF_MAX_HDR; #endif #endif

Sure enough, after removing those lines, wireless bridging just magically worked, but that's when the hard freezes began. This is VMWare WS 6 on RHEL5, running a WinXP VM. Core2Duo and an SMP kernel 2.6.18-8.1.8. madwifi 0.9.3.1. Sometimes the freeze happens as soon as the interface is bridged (at least, as soon as VMWare starts the VM), and sometimes the VM will run for a while, with working internet access, but eventually the machine will lock, no lights on my USB keyboard and mouse, no error messages in the logs upon reboot. I've found a few voicings of the complaint on the web, but no theories or solutions. I suppose it's a good guess that editing the driver source fouled things up. Or is the driver just unstable when bridging? I've only ever seen such a hard freeze with a hot CPU or bad RAM.

12/20/07 00:30:19 changed by mentor

  • priority changed from critical to major.