Please note: This project is no longer active. The website is kept online for historic purposes only.
If you´re looking for a Linux driver for your Atheros WLAN device, you should continue here .

Ticket #1109 (new defect)

Opened 15 years ago

Last modified 13 years ago

MadWifi trunk/0.9.2 ad-hoc network invisible to Windows

Reported by: pommnitz@yahoo.com Assigned to:
Priority: minor Milestone:
Component: madwifi: other Version: trunk
Keywords: ad-hoc windows Cc:
Patch is attached: 0 Pending:

Description

If I form an ad-hoc network from nodes running madwifi (either 0.9.2 or svn1995) Windows cannot see the network. Other ad-hoc networks show up just fine. I seem to remember that networks from madwifi-old were visible from Windows.

Change History

01/25/07 12:27:25 changed by mrenzmann

Could you please give further information on your setup (hardware as well as software)?

01/25/07 12:45:28 changed by pommnitz@yahoo.com

Hardware:

CPU: Intel Celeron 1Ghz WLAN: AR5212 Rev 1 (this is what lspci says)

Software: Linux 2.6.18.6 and Linux wireless tools version 27

The WinXP Laptops in question run SP2 on an Intel Centrino 802.11 interface. The Madwifi ad-hoc network is invisible to Netstumbler (see www dot netstumbler dot com) as well.

Anything else I could provide?

01/25/07 12:51:24 changed by mrenzmann

Yes, the settings you've applied to the MadWifi-driven Ad-hoc interface, please.

01/25/07 12:59:03 changed by anonymous

Nothing fancy:

ath0      IEEE 802.11b  ESSID:"55ad8882c3738422e06e34bb9df60518"  Nickname:"node005"
          Mode:Ad-Hoc  Frequency:2.427 GHz  Cell: 02:02:6F:23:12:03   
          Bit Rate:0 kb/s   Tx-Power:31 dBm   Sensitivity=0/3  
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=34/94  Signal level=-58 dBm  Noise level=-92 dBm
          Rx invalid nwid:5072  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

01/25/07 13:15:57 changed by pommnitz@yahoo.com

This might not be a problem with Madwifi after all. I just tried with another Laptop that uses a Broadcom BCM4310 and there WinXP found the Madwifi ad-hoc network just fine. I'm puzzled right now and would like to keep this issue open, but it should be downgraded.

01/26/07 06:05:17 changed by mrenzmann

  • priority changed from major to minor.
  • owner changed.
  • component changed from madwifi: 802.11 stack to madwifi: other.

01/26/07 10:19:56 changed by hotbar99@gmail.com

hello there,

I have same problem. I think... is it problem that special interface cannot make connection? in my test, every Intel Centrino interface cannot see any ad-hoc network by madwifi.(but madwifi can do.) also, madwifi cannot make ad-hoc connection with Intel Centrino interface. but, there is no problem, ad-hoc network with another interface.

nothing special my setting and connection test :

eth1      IEEE 802.11b  ESSID:"dtmania"
          Mode:Ad-Hoc  Frequency:2.462 GHz  Cell: 02:16:6F:01:5C:0C
          Bit Rate:0 kb/s   Tx-Power:14 dBm   Sensitivity=0/3
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=55/94  Signal level=-43 dBm  Noise level=-98 dBm
          Rx invalid nwid:0  Rx invalid crypt:111  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

uclibc[/]# ping 192.168.0.21
PING 192.168.0.21 (192.168.0.21): 56 data bytes

--- 192.168.0.21 ping statistics ---
28 packets transmitted, 0 packets received, 100% packet loss

"dtmania" is my ad-hoc network SSID by Intel Centrino, WINXP.

what do you think about this?

01/26/07 14:15:55 changed by pommnitz@yahoo.com

OK, so maybe there is a pattern here. As I wrote earlier: every Centrino-Laptop (IPW2200) I could get my hands on fails to see the Madwifi ad-hoc network, but the one Broadcom based one works just fine.

Is there a standard IEEE802.11 stack in WinXP or is it similiar to the current Linux situation: (almost) every driver for softmac interfaces comes with its own stack? If so, maybe the Intel stack less generous about what it is willing to accept than the Broadcom stack. I'm just guessing here, so if anybody knows, please let me know.

BTW: I'm going to send a note about this ticket to msdwifi-devel. Maybe somebody else has an idea.

04/16/08 22:02:56 changed by anonymous

Please look at post #6259 on the madwifi-devel mailing list. That post describes a possible work around for this problem.

07/19/08 15:13:28 changed by anonymous

In fact, I thought I have found the reason why these cards failure in Ad-hoc mode. Madwifi, iwl didn't transmit the beacons every 100ms. If you adapted a zd1211rw, you could see the beacons, but these madwifi, iwl didn't. In IEEE80211, if a node/cell didn't broadcast beacons for a time for example 1 minute, it would be looked as power off or out of the wireless range. All of you could found the same result if you adapted a zd1211rw/madwifi/iwl, switch the wireless mode to monitor mode and capture the wireless packages(Note: NOT IP package, but 80211 packages) with wireshark. Again, with the card didn't switch to monitor mode, can only capture IP packages. Only in monitor mode you could capture beacon packages.