Please note: This project is no longer active. The website is kept online for historic purposes only.
If you´re looking for a Linux driver for your Atheros WLAN device, you should continue here .

Ticket #1089 (new defect)

Opened 15 years ago

Last modified 15 years ago

wifi0: hardware error; reseting

Reported by: mpausch at klug-is dot de Assigned to:
Priority: major Milestone:
Component: madwifi: other Version:
Keywords: madwifi-ng-r1968-20070113 Cc:
Patch is attached: 0 Pending:

Description

Hello,

when I do a "ifconfig ath0 up" I get "wifi0: hardware error; reseting" in my /var/log/messages. The message repeates as long as my pcmcia-card is in the slot. CPU utilization is at 100%.

My hardware:
- Acer Travelmate 803
- Netgear WAG511v2 PCMCIA-Card (see the lspci -v output)

Ethernet controller: Atheros Communications, Inc. AR5212 802.11abg NIC (rev 01) [[BR]]
Subsystem: Netgear Unknown device 4610 [[BR]]
Flags: bus master, medium devsel, latency 168, IRQ 10 [[BR]]
Memory at 66000000 (32-bit, non-prefetchable) [size=64K] [[BR]]
Capabilities: <access denied>

Software:
- Kubuntu 6.10 Edgy Eft
- uname -a: Linux nb-076 2.6.17-10-generic #2 SMP Tue Dec 5 22:28:26 UTC 2006 i686 GNU/Linux
- madwifi: madwifi-ng-r1968-20070113 (Installed as described in http://madwifi.org/wiki/UserDocs/Distro/Ubuntu - but without the "CC=/usr/bin/gcc-3.4" in the make-commands)

The same error occured with the linux-restricted-modules package from kubuntu.

When I boot without the PCMCIA-Card in the slot and do the card into the slot when systemboot is finished "dmesg" shows me this additional lines:

[  293.563710] pccard: CardBus card inserted into slot 0
[  293.669668] ath_hal: 0.9.18.0 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
[  293.698494] wlan: 0.8.4.2 (svn r1968)
[  293.700449] ath_rate_sample: 1.2 (svn r1968)
[  293.706758] ath_pci: 0.9.4.5 (svn r1968)
[  293.707044] PCI: Enabling device 0000:03:00.0 (0000 -> 0002)
[  293.906568] wifi0: 11a rates: 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
[  293.906579] wifi0: 11b rates: 1Mbps 2Mbps 5.5Mbps 11Mbps
[  293.906584] wifi0: 11g rates: 1Mbps 2Mbps 5.5Mbps 11Mbps 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
[  293.906594] wifi0: turboA rates: 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
[  293.906601] wifi0: turboG rates: 6Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
[  293.906608] wifi0: H/W encryption support: WEP AES AES_CCM TKIP
[  293.906613] wifi0: mac 5.9 phy 4.3 radio 3.6
[  293.906617] wifi0: Use hw queue 1 for WME_AC_BE traffic
[  293.906620] wifi0: Use hw queue 0 for WME_AC_BK traffic
[  293.906622] wifi0: Use hw queue 2 for WME_AC_VI traffic
[  293.906625] wifi0: Use hw queue 3 for WME_AC_VO traffic
[  293.906627] wifi0: Use hw queue 8 for CAB traffic
[  293.906629] wifi0: Use hw queue 9 for beacons
[  293.912752] wifi0: Atheros 5212: mem=0x66000000, irq=10

On the same notebook I have WindowsXP SP2 running. And there the card works without problems. (It's really the same notebook and the same card. Not another card of the same type and not another notebook of the same type.)

If you need more information or something: pleas let me know.

Thank you and best regards

Manfred

Change History

01/20/07 17:57:33 changed by mpausch at klug-is dot de

Compiled the kernel with no smp support (# CONFIG_SMP is not set ). After that I compiled madwifi (same release and options as above). But when I make "ifconfig ath0 up" the problem still occurs.

Manfred

01/21/07 09:11:29 changed by rozteck@interia.pl

This message also appears on my IXP425 with 2.6.18-rt7 kernel when using Ubiquiti SR4 cards. The easiest way to got it is to made change txpower couple of times. But besides the error the card works...

02/04/07 22:55:52 changed by mpausch at klug-is dot de

Tried the Netgear-Card in another notebook (Lifebook E8210). In this notebook the card works without any problems. Possibly I will try the Card in the other notebook using your hint.