Please note: This project is no longer active. The website is kept online for historic purposes only.
If you´re looking for a Linux driver for your Atheros WLAN device, you should continue here .

Ticket #1088 (new defect)

Opened 15 years ago

Last modified 15 years ago

Hostapd with WPA not working - possible IOCTL error

Reported by: ConiKost Assigned to:
Priority: major Milestone:
Component: madwifi: driver Version: v0.9.2.1
Keywords: Cc:
Patch is attached: 0 Pending:

Description (Last modified by mrenzmann)

Hello!

I got here an miniPCI Atheros WLAN Card. I want to setup an WLAN AP!

I got managed it working without encryption. This works fine! But now, i need WPA.

So I installed hostapd 0.5.7 ... but i can't get it working. only getting this error:

Configuration file: /etc/hostapd/hostapd.conf
ioctl[IEEE80211_IOCTL_SETMLME]: Invalid argument
Could not connect to kernel driver.
Mode: IEEE 802.11g  Channel: 60  Frequency: 0 MHz
Using interface ath0 with hwaddr 00:14:85:d7:12:40 and ssid 'BlackBox.WLAN'
l2_packet_receive - recvfrom: Network is down

Debug:

BlackBox hostapd # hostapd -dd /etc/hostapd/hostapd.conf
Configuration file: /etc/hostapd/hostapd.conf
ctrl_interface_group=0
madwifi_set_iface_flags: dev_up=0
madwifi_set_privacy: enabled=0
BSS count 1, BSSID mask ff:ff:ff:ff:ff:ff (0 bits)
SIOCGIWRANGE: WE(compiled)=21 WE(source)=13 enc_capa=0xf
ath0: IEEE 802.11 Fetching hardware channel/rate support not supported.
Flushing old station entries
madwifi_sta_deauth: addr=ff:ff:ff:ff:ff:ff reason_code=3
ioctl[IEEE80211_IOCTL_SETMLME]: Invalid argument
madwifi_sta_deauth: Failed to deauth STA (addr ff:ff:ff:ff:ff:ff reason 3)
Could not connect to kernel driver.
Deauthenticate all stations
Mode: IEEE 802.11g  Channel: 6  Frequency: 0 MHz
madwifi_del_key: addr=00:00:00:00:00:00 key_idx=0
madwifi_del_key: addr=00:00:00:00:00:00 key_idx=1
madwifi_del_key: addr=00:00:00:00:00:00 key_idx=2
madwifi_del_key: addr=00:00:00:00:00:00 key_idx=3
Using interface ath0 with hwaddr 00:14:85:d7:12:40 and ssid 'BlackBox.WLAN'
SSID - hexdump_ascii(len=13):
     42 6c 61 63 6b 42 6f 78 2e 57 4c 41 4e            BlackBox.WLAN
PSK (ASCII passphrase) - hexdump_ascii(len=17):
     73 65 63 72 65 74 20 70 61 73 73 70 68 72 61 73   secret passphras
     65                                                e
PSK (from passphrase) - hexdump(len=32): 73 e3 fe 91 c5 01 12 a2 63 eb df 7b bc 34 b1 83 a8 f4 0a a1 9a cd eb 45 23 38 a9 de 39 e9 10 f5
madwifi_set_ieee8021x: enabled=1
madwifi_configure_wpa: group key cipher=1
madwifi_configure_wpa: pairwise key ciphers=0xa
madwifi_configure_wpa: key management algorithms=0x3
madwifi_configure_wpa: rsn capabilities=0x0
madwifi_configure_wpa: enable WPA=0x1
madwifi_set_privacy: enabled=0
WPA: group state machine entering state GTK_INIT (VLAN-ID 0)
GMK - hexdump(len=32): [REMOVED]
GTK - hexdump(len=32): [REMOVED]
WPA: group state machine entering state SETKEYSDONE (VLAN-ID 0)
madwifi_set_key: alg=TKIP addr=00:00:00:00:00:00 key_idx=1
madwifi_set_privacy: enabled=1
madwifi_set_iface_flags: dev_up=1
ath0: Setup of interface done.
l2_packet_receive - recvfrom: Network is down
Wireless event: cmd=0x8b1a len=22
Signal 2 received - terminating
Flushing old station entries
madwifi_sta_deauth: addr=ff:ff:ff:ff:ff:ff reason_code=3
Deauthenticate all stations
madwifi_set_privacy: enabled=0
madwifi_set_ieee8021x: enabled=0
madwifi_set_iface_flags: dev_up=0

http://www.bl4ckb0x.de/hostapd.conf

It madwifi-ng 0.9.2.1 not compatible with hostapd?

Change History

01/15/07 05:15:54 changed by mrenzmann

  • description changed.

MadWifi generally is compatible with HostAP. Otherwise we would have stated so.

Did you compile HostAP against the actual MadWifi version you use?

01/16/07 14:58:54 changed by anonymous

Yes, i use gentoo ;) So its compiled againts 0.9.2.1 !

01/18/07 11:47:25 changed by ConiKost

Nobody an Idea?

01/27/07 06:03:56 changed by Adian

I'm having the same problem with my setup, it seems. I'm running 0.9.2.1 against the latest debian 2.6.18 kernel sources. I'm currently using the hostapd that comes with debian. I have got this to work in the past with an older kernel and older (subversion) madwifi-ng drivers, so it's quite odd that it doesn't work now with a stable release. Oh, btw, I'm using an amd64 system, if that makes any difference.

If someone is willing to look into this, I can send/post kernel and other configs.

02/05/07 06:54:26 changed by madwifi@lazur.com

I'm having the exact same problem. I'm running Debian with a custom built 2.6.19.2 kernel. madwifi and hostapd have both been compiled from source and not from debian packages.

2.6.19.2 kernel .config file: pastebin.ca/340988

madwifi version: madwifi-ng r2069

"iwconfig ath0" (while hostapd running): pastebin.ca/340993

hostapd version: v0.5.7

hostapd.conf: pastebin.ca/340982

Output from: "hostapd -dd /etc/hostapd.conf": pastebin.ca/340983

* The pastebin.ca/<blargh> are URLs with the h-t-t-p stripped out so I could submit this comment.

02/05/07 07:01:53 changed by madwifi@lazur.com

Additional notes:

I'm using a DLink DWL-G510 NIC (firmware B1), which works just fine with madwifi in station mode, but not with hostapd in Master mode.

I've also tried all combinations and permutations of the Debian sources for madwifi (0.9.2+r1842.20061207-2) and hostapd (0.5.5-3.1) combined with the madwifi-ng svn (r2069) and current hostapd (v0.5.7).

I've also tried using kernel 2.6.15.7, with the same results as above.

02/18/07 13:06:25 changed by ConiKost

So will be there any fixes?

02/23/07 04:24:59 changed by anonymous

I have the same setup w/gentoo 2.6.18.3, and many hostap 0.4.x and hostap 0.5.x series (currently hostap 0.5.7) with madwifi-0.9.2.1 and I get similar messages. Is there a fix?

03/25/07 20:13:38 changed by anonymous

I'm also having this problem, on Debian etch. If any more information is required, I'd be happy to supply it.

03/25/07 22:54:13 changed by mentor

Maybe try: auth_algs = 1

03/26/07 00:57:38 changed by mentor

  • summary changed from Can't get working hostapd with madwifi-ng :( to Hostapd with WPA not working - possible IOCTL error.

03/26/07 05:37:44 changed by mentor

The SETMLME ioctl error is annoying but not actually fatal (at least in hostapd-0.5.7). So something else is going wrong...

04/15/07 12:14:26 changed by Alex <alex-nim@nm.ru>

another ticket with some error: [http ://madwifi.org/ticket/539]

04/16/07 14:37:50 changed by mrenzmann

r2225 addresses this issue, please test and give feedback.