Please note: This project is no longer active. The website is kept online for historic purposes only.
If you´re looking for a Linux driver for your Atheros WLAN device, you should continue here .

Ticket #1044 (new defect)

Opened 15 years ago

Last modified 15 years ago

Kernel crash in ath_rate/sample/sample.c:834

Reported by: ftchakou@bbn.com Assigned to:
Priority: major Milestone:
Component: madwifi: rate module 'sample' Version: trunk
Keywords: Cc:
Patch is attached: 0 Pending:

Description

First few lines of crash message are:

fixed rate 22 not in rate set<0>------------[ cut here ]------------ kernel BUG at /root/madwifi/ath_rate/sample/sample.c:834! invalid opcode: 0000 #1

Crash occurs at moderate-to-high traffic load. Traffic is initiated from or is directed to the Atheros-based node. Crashes are unpredictable in time but always occur in ath_rate/sample/sample.c:834.

Network environment: Atheros-based node (configured at a rate of 11Mbps) interoperating with 4 prism54-based nodes (all configured at a rate of 54 Mbps).

Attachments

crash.1 (4.0 kB) - added by anonymous on 12/14/06 02:14:04.
crash.1.txt (4.0 kB) - added by mentor on 06/02/07 03:16:53.
As above but text and formatted

Change History

12/14/06 02:14:04 changed by anonymous

  • attachment crash.1 added.

12/14/06 06:04:32 changed by mrenzmann

Which revision of trunk are you using exactly?

12/14/06 23:38:18 changed by ftchakou@bbn.com

I don't have any information about the retrieval date. The only snapshot information at hand is apparently what madwifi/release.h says:

$Id: release.h 1695 2006-07-27 12:25:18Z mrenzmann

#define RELEASE_TYPE "BETA"

#ifdef SVNVERSION #define RELEASE_VERSION SVNVERSION #else #define RELEASE_VERSION "0.9.3" #endif

Thanks

12/15/06 00:55:41 changed by anonymous

Can you check whether you get the same error with "onoe" algorithm? (UserDocs/RateControl)

12/15/06 11:42:32 changed by mrenzmann

If you retrieved your working copy with Subversion (svn), the command "svn info" should display the revision of the working copy. If you got a snapshot tarball instead, that contains a file call SNAPSHOT with similar information.

The information in release.h is unfortunately not helpful in this case.

12/15/06 14:30:33 changed by anonymous

I got the same error with amrr algorithm in the sense the system crashed with this:

fixed rate 22 not in rate set<0>------------[ cut here ]------------kernel BUG at /root/madwifi/ath_rate/amrr/amrr.c:303!

invalid opcode: 0000 #1 last sysfs file: /class/vc/vcsa3/dev Modules linked in: pswitch(U) pss_notify(U) nfsd(U) exportfs(U) lockd(U) nfs_acl (U) ipv6(U) autofs)CPU: 0 EIP: 0060:[<f8839341>] Tainted: P VLI

I didn't try onoe because I thought I would get the same problem.

I didn't get the tarball through subversion. I ran a %find command for SNAPSHOT and the file appears to be missing.

Thanks

06/02/07 03:16:53 changed by mentor

  • attachment crash.1.txt added.

As above but text and formatted

06/02/07 03:17:41 changed by mentor

Would you confirm that you are still experiencing these problems with latest trunk?