Please note: This project is no longer active. The website is kept online for historic purposes only.
If you´re looking for a Linux driver for your Atheros WLAN device, you should continue here .

Ticket #1023 (new defect)

Opened 15 years ago

Last modified 15 years ago

Madwifi driver hangs the 2.4.20-8 linux

Reported by: murahari.v@samsung.com Assigned to:
Priority: major Milestone:
Component: madwifi: other Version:
Keywords: Cc:
Patch is attached: 0 Pending:

Description

Hello All,

We are using the 3COM, 802.11a/b/g Wireless PC Card, 3CRPAG175-AP

Using the SVN (version r1794), I have downloaded the madwifi driver and installed on 2.4.20-8 kernel.

The driver is installed and works correctly for a small amount of time, 5 mts and then suddently the system hangs.

There are no kernel panic messages on the screen.

Based on the recommendation from the engineers, who have worked on madwifi driver, we have installed the diver on 2.4.22 kernel too. But we are getting the same problem here too.

Any pointers on this problem is appreciated

Best Regards, --Murahari

Change History

02/09/07 22:06:34 changed by olo

I've been using Madwifi-old driver for over a year on DLink cards that use the AR5212 chip. I get these random system hangs which I believe is the same problem you mentioned. The entire machine just freezes and needs a reboot. I switched to the Madwifi-ng code (rel. 0.9.2) and the system hangs are gone. Only that I now have problem locking the channels. I am using Madwifi with Kismet.

I tried to track down if there is any patches to the old codebase that fixes the system hang problem. There are different patches but seems to have mixed results from testings.

Can someone suggest a patch to the old codebase that works? Or else, is there a patch to the NG code base that fixes the channel locking problem?

olo

02/12/07 11:53:45 changed by mrenzmann

The old codebase is no longer supported, which reduces your chances to get any patches for that. Since you mention that the new codebase works fine for you, I wonder why you even bother to search fixes for madwifi-old.

02/12/07 16:42:58 changed by olo

Thanks for the reply but the new NG code does not lock channels. I am using Kismet to survey my wifi environment and when a network of interest is found I'd use Kismet to lock onto that particular channel (i.e. channels 1 - 12 in the case of 802.11.b/g) But NG doesn't lock on the channel (the old code does). I wonder if there is a change of API from the old to the new NG code which makes Kismet obsolete. But I have read several tickets reporting the same problem ... even with a simple iwconfig ... (i.e. iwconfig wifi0 channel 6).

For example, someone wrote in ticket #695 - channel hopping in master mode - unable to lock channel ...

"My atheros card still hopping around whole 2.4GHz spectrum. Locking with "iwconfig ath1 channel 2" doesn't help nor "athchans -i ath1 2". "

"I have the same problem with my ubiquiti card in debian and fedora, but only with the ng driver. The old madwifi works perfectly. "

olo

02/12/07 17:02:00 changed by mrenzmann

Did you already try to disable background scanning (iwconfig ath0 bgscan 0)?

02/12/07 17:41:53 changed by anonymous

Thanks. I tried turning off bgscan just now... the kernel rejected the command with

Error: unrecognised wireless request "bgscan" Am I using the wrong wireless extension?

iwconfig -v shows me these ...

iwconfig Wireless-Tools version 27

Compatible with Wireless Extension v11 to v17

Kernel Currently compiled with Wireless Extension v19

ath0 Recommend Wireless Extension v13 or later

Currently compiled with Wireless Extension v19

ath1 Recommend Wireless Extension v13 or later

Currently compiled with Wireless Extension v19

kis Recommend Wireless Extension v13 or later

Currently compiled with Wireless Extension v19

One observation though.. I am using 2 DLink cards. Both using Atheros chip. I can lock channel from Kismet only if lock both cards to the same channel. I thought that's odd.

olo

02/12/07 17:44:45 changed by anonymous

Just a quick note: I think #572 and #433 are talking about the same problem. Seems like a major issue with no solution.

olo

02/13/07 06:57:58 changed by mrenzmann

Am I using the wrong wireless extension?

No, I'm just too dumb to type. Try iwpriv ath0 bgscan 0 instead (iwpriv rather than iwconfig). Sorry for the confusion.

02/13/07 17:20:20 changed by olo

Thanks. The iwpriv command made no difference. Still can't lock channel.

Interesting thing is ... I have 2 WiFi cards running Atheros chip, I wasn't able to lock channel unless I lock both cards to the same channel. Let say I lock the first card to chan-6, it won't lock until I lock the 2nd card to chan-6 as well. Strange!

I was running Kismet to control the cards. Everything works fine with the old codebase...

olo

02/14/07 17:06:31 changed by JR

I have the same problem. My system often hangs after running for about 3 to 8 hours.. It simply freezes everything with no kernel panic. No idea how to debug this. It was running MADWifi-NG rel. 0.9.2 on a Fedora Core 3, 2.6.15 Kernel. I was also running multiple WiFi cards that use the Atheros chip. I tried the old code and it has the same problem... JR

02/16/07 22:12:50 changed by mentor

Try looking in /proc/slabinfo to see if the one of the caches is running out of space...